当前位置: 主页 > 交易技巧 >

寿光果菜交易所MACD周线公式

日期:2018-06-15 03:46  浏览: 次  责任编辑:网站编辑

☆ ☆ 潘启明博客内检索  ☆ ☆

返回《总目录》 | 返回《股市公式目录》

股票公式目录
MACD周线公式
修改比尔·威廉姆斯公式
慢速随机目标
写买卖目标公式
又是BOLL公式
直观买卖公式
资金出进目标公式
放量警示目标公式
MACD目标公式
换手率目标公式
买卖顶底目标公式
买卖操作目标
布林线目标
加一个卖点
《资金进出》公式
抛物停转
选股选时
《价量背离》公式
《买卖主力》公式
买卖量公式
《威廉》目标变形
《多空博奕》公式
同花顺《右侧操作》公式
买卖点位目标
通达信《右侧操作》公式
通达信《买卖T+0》公式
大智慧使用的字符串
大智慧自己的函数使用说明
大智慧的十大类函数
金点100
股票公式的财务数据
同花顺公式目标
资金出进公式
一分钟双向成交量
《资金流向》公式
我学公式、写公式
双向买卖公式
我常用的公式
自编同花顺公式
进场时刻
未来函数
选股公式
买卖量公式
去掉多余的器械
股票操作公式
箱体公式
买卖预先挂单
显示买卖点位
板块轮动
买卖量上找主力
买要算,卖要看
和讯数据更好用
同花顺主力买卖代码
资金流向和主力资金
新编买卖操作目标说明
觅找得当自己的公式
公式函数
怎样写函数
函数代码的使用说明
自己写 T+0 公式
函数买卖点位的图像显示
股票技术分析
函数的一些处理方法

MACD周线公式

  2011-07-31 22:51,有朋友给我发贴说,

    潘老师,这个怎么改成通达信的?
    {用在30分钟K线图上的日线/周线MACD红绿柱面积(大智慧L2版),在30分钟K线图上显示日线、周线MACD}
    DIFF1:=EMA(CLOSE,96) - EMA(CLOSE,208);
    DEA1:=EMA(DIFF1,72);
    MACD:=2*(DIFF1-DEA1);
    DIFFz:=EMA(CLOSE,480) - EMA(CLOSE,1040);
    DEAz:=EMA(DIFFz,360);
    MACDz:=2*(DIFFz-DEAz);
    MACD日线:MACD,COLOR0000FF,LINETHICK0;
    DIFF日线:DIFF1,Color0000FF;
    DEA日线:DEA1,ColorFF0000;
    MACD周线:MACDz,ColorFF00FF,LINETHICK0;
    DIFF周线:DIFFz,ColorFF00FF;
    DEA周线:DEAz,Color00FF00;
    绿柱面积:10*IF (MACD<0,SUM(MACD,BARSLAST(MACD>0)),0),LINETHICK0,colorred;
    红柱面积:10*IF (MACD>0,SUM(MACD,BARSLAST(MACD<0)),0),LINETHICK0,Color00ff00;
    MACDhs:=IF(MACD>0 AND MACD>=REF(MACD,1),MACD,0);
    MACDhx:=IF(MACD>0 AND MACD<=REF(MACD,1),MACD,0);
    MACDlx:=IF(MACD<0 AND MACD<REF(MACD,1),MACD,0);
    MACDls:=IF(MACD<0 AND MACD>REF(MACD,1),MACD,0);
    STICKLINE(MACDz>0 AND MACDz>=REF(MACDz,1),0,MACDz,6,1),ColorFF99FF;
    STICKLINE(MACDz>0 AND MACDz<REF(MACDz,1),0,MACDz,6,1),Color99ffFF;
    STICKLINE(MACDz<0 AND MACDz<=REF(MACDz,1),0,MACDz,6,1),ColorFFbb99;
    STICKLINE(MACDz<0 AND MACDz>REF(MACDz,1),0,MACDz,6,1),ColorbbFFbb;
    STICKLINE(MACDhs>0,0,MACD,9,0),Color0000BB;
    STICKLINE(MACDhs>0,0,MACD,8,0),Color0000CC;
    STICKLINE(MACDhs>0,0,MACD,7,0),Color0011CC;
    STICKLINE(MACDhs>0,0,MACD,6,0),Color1122DD;
    STICKLINE(MACDhs>0,0,MACD,5,0),Color2233DD;
    STICKLINE(MACDhs>0,0,MACD,4,0),Color3344EE;
    STICKLINE(MACDhs>0,0,MACD,3,0),Color4455EE;
    STICKLINE(MACDhs>0,0,MACD,2,0),Color5566FF;
    STICKLINE(MACDhs>0,0,MACD,1,0),Color6677FF;
    STICKLINE(MACDhx>0,0,MACD,9,0),Color0077BB;
    STICKLINE(MACDhx>0,0,MACD,8,0),Color0088CC;
    STICKLINE(MACDhx>0,0,MACD,7,0),Color0099CC;
    STICKLINE(MACDhx>0,0,MACD,6,0),Color00AADD;
    STICKLINE(MACDhx>0,0,MACD,5,0),Color00BBDD;
    STICKLINE(MACDhx>0,0,MACD,4,0),Color00CCEE;
    STICKLINE(MACDhx>0,0,MACD,3,0),Color00DDEE;
    STICKLINE(MACDhx>0,0,MACD,2,0),Color00EEFF;
    STICKLINE(MACDhx>0,0,MACD,1,0),Color00FFFF;
    STICKLINE(MACDlx<0,MACD,0,9,0),Color770000;
    STICKLINE(MACDlx<0,MACD,0,8,0),Color881100;
    STICKLINE(MACDlx<0,MACD,0,7,0),Color992200;
    STICKLINE(MACDlx<0,MACD,0,6,0),ColorAA3300;
    STICKLINE(MACDlx<0,MACD,0,5,0),ColorBB4400;
    STICKLINE(MACDlx<0,MACD,0,4,0),ColorCC5500;
    STICKLINE(MACDlx<0,MACD,0,3,0),ColorDD6600;
    STICKLINE(MACDlx<0,MACD,0,2,0),ColorEE7700;
    STICKLINE(MACDlx<0,MACD,0,1,0),ColorFF8800;
    STICKLINE(MACDls<0,MACD,0,9,0),Color005500;
    STICKLINE(MACDls<0,MACD,0,8,0),Color007700;
    STICKLINE(MACDls<0,MACD,0,7,0),Color009900;
    STICKLINE(MACDls<0,MACD,0,6,0),Color00AA00;
    STICKLINE(MACDls<0,MACD,0,5,0),Color00BB00;
    STICKLINE(MACDls<0,MACD,0,4,0),Color00CC00;
    STICKLINE(MACDls<0,MACD,0,3,0),Color00DD00;
    STICKLINE(MACDls<0,MACD,0,2,0),Color00EE00;
    STICKLINE(MACDls<0,MACD,0,1,0),Color00FF00;
    DRAWTEXT(ref(MACD,1)>0 and MACD<=0 ,HHV(MACD,8),''+ref(红柱面积,1)),ALIGN1,VALIGN1,colorred;
    DRAWTEXT(ref(MACD,1)<0 and MACD>=0 ,LLV(MACD,4),''+ref(abs(绿柱面积),1)),ALIGN1,Color00ff00;
    DRAWTEXT(BARSTATUS=2 AND MACD<0,LLV(MACD,8),''+abs(绿柱面积)),align2,Color00AA00;
    DRAWTEXT(BARSTATUS=2 AND MACD>0,HHV(MACD,4),''+abs(红柱面积)),align2,VALIGN1,colorred;

  我讲过,因为我的职业是教师,所以我喜欢授渔而不售鱼。所以我今天想展示一下我是如何学习写股票目标公式的。

  电脑是把傻瓜变成聪明人,把聪明人变成傻瓜的科技发现。

  不识字的孩子们,可能电脑玩得比汉语和外语老教授还厉害。

  所以写公式是每个有中学文化水平都可以做的事情。

  我可以读古文,但对电脑的程序语言一无所知。但电脑是可以DIY(do it yourself)的发现。就是我们中国的传统做法,输进信息,然后看它的反馈。

  我的办法,就是一个号令一个号令地看它是干什么的。然后修改一点点,看它有会产生什么变化。

  我没有大智慧L2版,无法知道它们在现实运用中是什么长相。

  但MACD是在所有行情软件中都能展示的。

☆ ☆ ☆

  首先在通达信上执行它。发现上面的公式的最后四行,在通达信软件中不能使用。可以删除它们。

  因为DRAWTEXT作用只是在窗口显示几个字,去掉它们没有关系。如果要尽量保留它,只能是:

    DRAWTEXT(REF(MACD,1)>0 AND MACD<=0 ,HHV(MACD,8),'红'),COLORRED;
    DRAWTEXT(REF(MACD,1)<0 AND MACD>=0 ,LLV(MACD,4),'红'),COLOR00FF00;

  删除了不能展示的部分之后,在软件中展示出这种图像。

查看更多出色图片

 

  到此为止,我已经完成了朋友要我把它“改成通达信的”任务。

  但我看不出它有什么用,所以我换了一收股票来看:

查看更多出色图片

 

  我还是看不出这个公式有什么意义。所以我决定去掉所有的立柱。结果发现linethick0不能展示,把0改为1;而绿柱/红柱面积数值太大,和其它项目不成比例,因此用DODRAW不显示图像,只显示数值。颜色也缺少变化,重新定义了颜色,给每条线一个单独的颜色。结果是:

查看更多出色图片

 

  然后,只展示MACD日线(MACD的图形和MACD日线图形一样)。为了比力,我鄙人面又开了一个窗口,展示原来的MACD。我看不出它有什么用。

查看更多出色图片

 

  然后,只展示MACD周线。我也看不出它有什么用。

查看更多出色图片

 

  还是看不出它有什么用。然后展示和MACDz有关的立柱:

    STICKLINE(MACDz>0 AND MACDz>=REF(MACDz,1),0,MACDz,6,1),ColorFF99FF;
    STICKLINE(MACDz>0 AND MACDz<REF(MACDz,1),0,MACDz,6,1),Color99ffFF;
    STICKLINE(MACDz<0 AND MACDz<=REF(MACDz,1),0,MACDz,6,1),ColorFFbb99;
    STICKLINE(MACDz<0 AND MACDz>REF(MACDz,1),0,MACDz,6,1),ColorbbFFbb;

查看更多出色图片

 

  还是看不出它有什么用。然后展示和MACDhs有关的立柱:

    STICKLINE(MACDhs>0,0,MACD,9,0),Color0000BB;
    STICKLINE(MACDhs>0,0,MACD,8,0),Color0000CC;
    STICKLINE(MACDhs>0,0,MACD,7,0),Color0011CC;
    STICKLINE(MACDhs>0,0,MACD,6,0),Color1122DD;
    STICKLINE(MACDhs>0,0,MACD,5,0),Color2233DD;
    STICKLINE(MACDhs>0,0,MACD,4,0),Color3344EE;
    STICKLINE(MACDhs>0,0,MACD,3,0),Color4455EE;
    STICKLINE(MACDhs>0,0,MACD,2,0),Color5566FF;
    STICKLINE(MACDhs>0,0,MACD,1,0),Color6677FF;

查看更多出色图片

 

  还是看不出它有什么用。然后展示和MACDhs有关的立柱:

    查看更多出色图片

     

      还是看不出它有什么用。然后展示和MACDhx有关的立柱:

      STICKLINE(MACDhx>0,0,MACD,9,0),Color0077BB;
      STICKLINE(MACDhx>0,0,MACD,8,0),Color0088CC;
      STICKLINE(MACDhx>0,0,MACD,7,0),Color0099CC;
      STICKLINE(MACDhx>0,0,MACD,6,0),Color00AADD;
      STICKLINE(MACDhx>0,0,MACD,5,0),Color00BBDD;
      STICKLINE(MACDhx>0,0,MACD,4,0),Color00CCEE;
      STICKLINE(MACDhx>0,0,MACD,3,0),Color00DDEE;
      STICKLINE(MACDhx>0,0,MACD,2,0),Color00EEFF;
      STICKLINE(MACDhx>0,0,MACD,1,0),Color00FFFF;

    查看更多出色图片

     

      还是看不出它有什么用。然后展示和MACDlx有关的立柱:

      STICKLINE(MACDlx<0,MACD,0,9,0),Color770000;
      STICKLINE(MACDlx<0,MACD,0,8,0),Color881100;
      STICKLINE(MACDlx<0,MACD,0,7,0),Color992200;
      STICKLINE(MACDlx<0,MACD,0,6,0),ColorAA3300;
      STICKLINE(MACDlx<0,MACD,0,5,0),ColorBB4400;
      STICKLINE(MACDlx<0,MACD,0,4,0),ColorCC5500;
      STICKLINE(MACDlx<0,MACD,0,3,0),ColorDD6600;
      STICKLINE(MACDlx<0,MACD,0,2,0),ColorEE7700;
      STICKLINE(MACDlx<0,MACD,0,1,0),ColorFF8800;

    查看更多出色图片

     

      还是看不出它有什么用。然后展示和MACDls有关的立柱:

      STICKLINE(MACDls<0,MACD,0,9,0),Color005500;
      STICKLINE(MACDls<0,MACD,0,8,0),Color007700;
      STICKLINE(MACDls<0,MACD,0,7,0),Color009900;
      STICKLINE(MACDls<0,MACD,0,6,0),Color00AA00;
      STICKLINE(MACDls<0,MACD,0,5,0),Color00BB00;
      STICKLINE(MACDls<0,MACD,0,4,0),Color00CC00;
      STICKLINE(MACDls<0,MACD,0,3,0),Color00DD00;
      STICKLINE(MACDls<0,MACD,0,2,0),Color00EE00;
      STICKLINE(MACDls<0,MACD,0,1,0),Color00FF00;

    查看更多出色图片

     

    ☆ ☆ ☆

      所有的立柱都展示完了,我仍然看不出它们对股票操盘有什么作用。

      不过在MACD中,一般取值都是很小的。SHORT一般取12;LONG取26;MID取9。

      所谓MACD周线,无非就是加大SHORT、LONG、MID取值的倍数。

      如果它们能取合理的值,会是很有意义的。

      如果是我,我不会把colorstick搞得很复杂,而会在SHORT、LONG、MID的取值上下工夫。

    返回《股市公式目录》 | 返回《总目录》


    山东寿光蔬菜产业集团(青岛)商品交易所交流群98489271
    本文地址:寿光果菜交易所MACD周线公式 http://www.tiebot.com/a/jiaoyijiqiao/2018/0615/7668.html
    所有文章均由山东寿光果蔬交易所,青岛西海岸商品交易中心原创或网络收集,仅供学习参考之用,如有错误、侵权之处请及时联系我们修改、删除,若有转载,请注明出处!谢谢!

    栏目列表

    联系我们

      开户咨询:
      技术咨询:
      服务热线
      交流 Q群寿光蔬菜
      公司网址:www.tiebot.com

    最新文章

    果菜简介

          山东寿光蔬菜产业集团(青岛)商品交易市场有限公司(以下简称交易市场)位于国家级新区青岛西海岸新区,是经青岛市大宗商品交易市场规范健康发展联席会议办公室授权青岛西海岸新区管委批准的进行农副产品现货商品交易的市 交易市场依托山东寿光蔬菜产业集团的现货优势以及西海岸新区的政策优势、环境优势、区位优势,通过专业严格的市场管理及优质的配套服务,以覆盖全国的仓储物流体系和服务机构为基础,配合结算银行安全快捷的结算体系,以建设多层次、高标准的综合型现货贸易平台为宗旨,