当前位置: 主页 > 交易技巧 >

山东寿光果蔬交易所【转】变色MACD指标

日期:2015-07-31 21:33  浏览: 次  责任编辑:网站编辑

 

没有万能的指标。大家记住,只有理念及适开自己的操作规则才能历久盈利,比如一个简单的不能再简单的操作规则,指数收盘在10日线上持股,上五日线,全仓,下五日线减半仓。下10日线,出局。当然,这只是举例。就这简单的操作规则另有很多种情况,比如缠绕,上穿下穿,线位,交叉面积等,实战中需要累积丰富的经验,才能矫捷操作,有规则而不拘泥于规则。大家可以根据自己的资金情况,持股周期等来研究适开自己的操作规则。

 

通达信设置办法,功能,专家系统,公式管理器。新建。之后大家应该自己懂了。

 

参数设置:

SHORT:2,200,12 。LONG:2,200,26。MID:2,200,9。

公式源码:

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
MACD:(DIF-DEA)*2,COLORSTICK;
IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN,LINETHICK2;
IF(DIF>=REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
{MACD提示};
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)> C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
DRAWICON(B1>0,DIF*1.21,1);{MACD底背离}
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)> "MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");
DRAWICON(D1>0,DEA*1.21,2);{MACD顶背离};

 

 

以下是小老虎悛改的变色MACD:

DIFF:(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26),COLORRED;
DEA:EMA(DIFF,9),COLORRED,LINETHICK2;
DIF:IF(DIFF<REF(DIFF,1),DIFF,DRAWNULL),COLORGREEN;
ADEA:IF(DEA<REF(DEA,1),DEA,DRAWNULL),COLORGREEN,LINETHICK2;
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(背离,0,3,2,0),COLOR00FF00;
DRAWLINE(A1=0,DEA,背离,DEA,0),COLORRED;
DRAWTEXT(背离,5.2,' 背离');
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.5,0),COLORFF00FF;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,0.5,0)COLOR00FF00;
STICKLINE(MACD>REF(MACD,1)AND MACD,0,MACD,0.5,0),COLORYELLOW;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,0.5,0),COLORRED;
IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN,LINETHICK2;
IF(DIF>=REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
{MACD提示};
A2:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A2+1)> C AND REF("MACD.DIF",A2+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
DRAWICON(B1>0,DIF*1.21,1);{MACD底背离}
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)> "MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");
DRAWICON(D1>0,DEA*1.21,2);{MACD顶背离};

 

    


山东寿光蔬菜产业集团商品交易所交流群98489271
本文地址:山东寿光果蔬交易所【转】变色MACD指标 http://www.tiebot.com/a/jiaoyijiqiao/2015/0731/1172.html
所有文章均由山东寿光果蔬交易所,青岛西海岸商品交易中心原创或网络收集,仅供学习参考之用,如有错误、侵权之处请及时联系我们修改、删除,若有转载,请注明出处!谢谢!

栏目列表

联系我们

    开户咨询:
    技术咨询:
    服务热线
    交流 Q群寿光蔬菜
    公司网址:www.tiebot.com

果菜简介

        山东寿光蔬菜产业集团(青岛)商品交易市场有限公司(以下简称交易市场)位于国家级新区青岛西海岸新区,是经青岛市大宗商品交易市场规范健康发展联席会议办公室授权青岛西海岸新区管委批准的进行农副产品现货商品交易的市 交易市场依托山东寿光蔬菜产业集团的现货优势以及西海岸新区的政策优势、环境优势、区位优势,通过专业严格的市场管理及优质的配套服务,以覆盖全国的仓储物流体系和服务机构为基础,配合结算银行安全快捷的结算体系,以建设多层次、高标准的综合型现货贸易平台为宗旨,